Resolved:ParkMobile users may experience an issue with intermittent slowness and timeouts with reservation orders.

Incident Report for ParkMobile

Resolved

Status: Resolved: Our teams have resolved the system disruption that was causing an issue with reservation orders and timeouts. ParkMobile applications are operating as designed, and we will continue to monitor the system recovery.

Impacted:
- Users may experience timeouts with purchasing reservations.


Not impacted:
- Zone parking users continue to have full, uninterrupted service.

Incident Start Time:
- 10:39 AM ET on June 18th, 2026

Incident End Time:
- 11:50 AM ET on June 18th, 2026

Thank you for your patience during this time. If you have any questions, please reach out to your ParkMobile Account Manager.
Posted Jun 19, 2026 - 09:53 EDT

Update

Status: Resolved: Our teams have resolved the system disruption that was causing an issue with reservation orders and timeouts. ParkMobile applications are operating as designed, and we will continue to monitor the system recovery.

Impacted:
- Users may experience timeouts with purchasing reservations.


Not impacted:
- Zone parking users continue to have full, uninterrupted service.

Incident Start Time:
- 10:39 AM ET on June 18th, 2026

Incident End Time:
- 11:50 AM ET onJune 18th, 2026

Thank you for your patience during this time. If you have any questions, please reach out to your ParkMobile Account Manager.
Posted Jun 19, 2026 - 09:49 EDT

Update

We are continuing to monitor for any further issues.
Posted Jun 18, 2026 - 12:00 EDT

Monitoring

Status: Resolved: Our teams have resolved the system disruption that was causing an issue with reservation orders and timeouts. ParkMobile applications are operating as designed, and we will continue to monitor the system recovery.

Impacted:
- Users may experience timeouts with purchasing reservations.


Not impacted:
- Zone parking users continue to have full, uninterrupted service.

Incident Start Time:
- 10:39 AM ET on June 18th, 2026

Incident End Time:
- 11:50 AM ET onJune 18th, 2026

Thank you for your patience during this time. If you have any questions, please reach out to your ParkMobile Account Manager.
Posted Jun 18, 2026 - 11:56 EDT

Investigating

Status: ParkMobile is investigating a system disruption that is causing intermittent slowness with reservation orders.
Impacted:
- Users may experience timeouts with purchasing reservations.

Alternatives:
- If you experience a timeout please try again.

Not impacted:
- Zone parking is operating as expected.

Next steps:
- We will keep this page updated with our progress.

If you have any questions, please reach out to your ParkMobile Account Manager.
Posted Jun 18, 2026 - 11:36 EDT
This incident affected: ParkMobile Reservations (Reservations - Web) and ParkMobile Core Application (ParkMobile Application (Reserved Parking) - iOS, ParkMobile Application (Reserved Parking) - Android).