Cybersource service disruption July 15th Start Time: 7:15 PM

Incident Report for ParkMobile

Monitoring

Status: ParkMobile was notified that Cybersource has confirmed that mitigations have been put in place and platform performance has returned to normal.

Impacted:
- Payments timed out, and some users may have experienced difficulty starting parking sessions.


Reported start time: Jul 15 7:15 pm ET
Reported end time: Jul 16 9:00 pm ET

Next steps:
- We will continue to monitor the resolution. For updates from Cybersource on this disruption, please visit https://status.cybersource.com/incidents/ry0rqlcp824c

If you have any questions, please reach out to your ParkMobile Account Manager.
Posted Jul 16, 2026 - 05:37 EDT

Identified

Status: ParkMobile was notified that Cybersource is currently investigating a service disruption.

Impacted:
- Payments timed out, and some users may have experienced difficulty starting parking sessions.


Incident Start Time:
- TBD

Next steps:
- We will continue to monitor the resolution. For updates from Cybersource on this disruption, please visit https://status.cybersource.com/incidents/ry0rqlcp824c

If you have any questions, please reach out to your ParkMobile Account Manager.
Posted Jul 15, 2026 - 19:50 EDT
This incident affects: Payments (Third-Party Payment Processing).