Elavon service issue - Resolved

Incident Report for ParkMobile

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 14:01 EDT

Monitoring

ParkMobile was notified that Elavon experienced a payment processing delay between 16:58 Eastern Time and 18:32 Eastern Time. This caused some payments to fail during this time. Failed payments were automatically reversed, and no funds were collected for affected sessions.

Elavon has reported that the incident has been resolved. For updated Elavon status, please see https://status.elavon.com/.

Please reach out to your ParkMobile Account Manager if you have any additional questions.
Posted Jun 25, 2025 - 19:59 EDT
This incident affected: Other.