Cleared Transaction Report and Parking Dashboard may be missing transaction data from April 17, 2025

Incident Report for ParkMobile

Resolved

This incident has been resolved.
Posted Apr 20, 2025 - 13:31 EDT

Identified

Cleared Transaction Report and Parking Dashboard may be missing transaction data from April 17, 2025. Teams are actively working to correct the data.

Please reach out to your Account Manager if you have questions.
Posted Apr 18, 2025 - 12:53 EDT
This incident affected: ParkMobile 360 (ParkMobile 360 - Reporting).