Resolved: ParkMobile users did not receive welcome email when Dashboard account was created

Incident Report for ParkMobile

Update

We are continuing to monitor for any further issues.
Posted Mar 03, 2026 - 12:01 EST

Monitoring

Status: Our teams have resolved the system disruption that caused new users to not receive the welcome email to the Parking Dashboard. ParkMobile applications are operating as designed, and we will continue to monitor the system recovery.

Impacted:
- New users did not receive the welcome email when their Parking Dashboard account was created. Users who did not receive a welcome email can select "Forgot Password" at the login screen to have a new email reset sent to them.

Not impacted:
- No disruption to Parking Dashboard operational functions.

Incident Start Time:
- 03:30 AM 2/26/2026

Incident End Time:
- 05:21 AM 3/3/2026

Thank you for your patience during this time. If you have any questions, please reach out to your ParkMobile Account Manager.
Posted Mar 03, 2026 - 09:46 EST
This incident affects: Other.