Resolved: Brief payment service disruption | March 18 10:20am ET - 10:36am ET

Incident Report for ParkMobile

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 13:00 EDT

Monitoring

Status: Resolved - ParkMobile experienced a brief disruption with a payment service provider. Payment processing has fully recovered, and all systems are now operating as designed. We will continue to monitor the system recovery.

Impacted:
- Payment Processing: During this 16-minute window, users may have experienced slowness or timed-out requests while attempting to process session payments.

Not Impacted:
- Existing parking sessions remained active and were not affected by this disruption.

Incident Start Time:
- March 18 10:20am ET

Incident End Time:
- March 18 10:36am ET

Thank you for your patience during this time. If you have any questions, please reach out to your ParkMobile Account Manager.
Posted Mar 18, 2026 - 10:55 EDT
This incident affected: Payments (Third-Party Payment Processing).