Resolved: Cybersource service disruption | Nov 19 10:29pm ET - Nov 21 7:16pm ET

Incident Report for ParkMobile

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 08:22 EST

Monitoring

The Cybersource service disruption was resolved. ParkMobile will continue to assess any impact to settlement of funds into First Data merchant accounts and communicate with those impacted.

Reported start time: Nov 19 10:29pm ET
Reported end time: Nov 21 7:16pm ET

Please reach out to your ParkMobile Account Manager if you have any additional questions.
Posted Nov 23, 2025 - 13:25 EST

Investigating

Status: ParkMobile was notified that Cybersource is currently investigating a service disruption.

Impact: For operators who use First Data for payment processing, this may delay settlement of funds into merchant accounts. This does not impact the ability for users to pay for parking sessions.

We will continue to monitor impact. For updates from Cybersource on this disruption, please visit https://status.cybersource.com/incidents/vfg8w0qf3m38.

Please reach out to your ParkMobile Account Manager if you have any additional questions.
Posted Nov 21, 2025 - 19:01 EST
This incident affected: Payments (Third-Party Payment Processing).