ParkMobile mobile and web applications operating as designed

Incident Report for ParkMobile

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 10:34 EST

Update

ParkMobile's customer service chat in the mobile app is available.

ParkMobile mobile and web systems are currently operating as designed. Other third-party services may experience impacts, which we will continue to monitor.
Posted Nov 18, 2025 - 09:50 EST

Monitoring

We understand some clients may have received an email regarding potential impacts to Arrive systems stemming from the current Cloudflare service disruption.

ParkMobile mobile and web systems are currently operating as designed. Other third-party services may experience impacts, which we will continue to monitor.

ParkMobile's customer service chat in the mobile app is currently unavailable. To contact our team for support, please visit https://parkmobile.io/contact-us.
Posted Nov 18, 2025 - 09:06 EST